gp6.10安装mysql_fdw报错
 
通知
清除全部

gp6.10安装mysql_fdw报错


781730117
帖子: 2
Topic starter
初出茅庐
已加入: 5月 前

_环境:gp6.10,mysql-8.0.23-linux-glibc2.12-x86_64  mysql_fdw插件使用 https://gitee.com/icefairy/mysql_fdw_greenplum

编译安装

运行 create extension mysql_fdw

ERROR:failed to load the mysql query:

libcrypto.so.1.1:cannot open shared object file:No such file or directory

HINT:export LD_LIBRARY_PATH to locate the library

没有安装 yum install libmysqlclient-dev,请问避免上面的错误

 

1 Reply
781730117
帖子: 2
Topic starter
初出茅庐
已加入: 5月 前

问题已经解决了,是由于没有 LD_LIBRARY_PATH 中药包含 $MYSQL_HOME/lib/private 这个路径

回复

关注微信公众号

Greenplum中文社区

Greenplum官方微信群

扫码加入我们的技术讨论,请备注“网站”