在现有的数据节点上扩容报错
 
通知
清除全部

在现有的数据节点上扩容报错  


xzg1109
帖子: 2
初出茅庐
已加入: 2周 前

20201116:16:07:30:016541 gpexpand:master27:gpadmin-[ERROR]:-gpexpand failed: ExecutionError: 'non-zero rc: 127' occurred. Details: 'ssh -o StrictHostKeyChecking=no -o ServerAliveInterval=60 slave28 ". /usr/local/greenplum-db-6.9.0/greenplum_path.sh; /bin/scp /opt/data/gpdatap1/gpseg0/postgresql.conf master27:/opt/data/gpmaster/gpexpand_11162020_16541"' cmd had rc=127 completed=True halted=False
stdout=''
stderr='bash: /bin/scp: No such file or directory
'

Exiting...
20201116:16:07:30:016541 gpexpand:master27:gpadmin-[ERROR]:-Please run 'gpexpand -r' to rollback to the original state.

 

扩容文件

slave28|slave28|6002|/opt/data/gpdatap3/gpseg12|14|12|p
slave28|slave28|6003|/opt/data/gpdatap4/gpseg13|15|13|p
slave29|slave29|6002|/opt/data/gpdatap3/gpseg14|16|14|p
slave29|slave29|6003|/opt/data/gpdatap4/gpseg15|17|15|p
slave31|slave31|6002|/opt/data/gpdatap3/gpseg16|18|16|p
slave31|slave31|6003|/opt/data/gpdatap4/gpseg17|19|17|p
slave32|slave32|6002|/opt/data/gpdatap3/gpseg18|20|18|p
slave32|slave32|6003|/opt/data/gpdatap4/gpseg19|21|19|p
slave33|slave33|6002|/opt/data/gpdatap3/gpseg20|22|20|p
slave33|slave33|6003|/opt/data/gpdatap4/gpseg21|23|21|p
slave34|slave34|6002|/opt/data/gpdatap3/gpseg22|24|22|p
slave34|slave34|6003|/opt/data/gpdatap4/gpseg23|25|23|p

问题标签
3 回复
小青梅
帖子: 38
Admin
青梅少侠
已加入: 6月 前

需要装一下scp...

回复
1 回复
xzg1109
已加入: 2周 前

初出茅庐
帖子: 2

@aduanvmware-com

[gpadmin@master27 ~]$ /bin/scp
usage: scp [-12346BCpqrv] [-c cipher] [-F ssh_config] [-i identity_file]
[-l limit] [-o ssh_option] [-P port] [-S program]
[[user@]host1:]file1 ... [[user@]host2:]file2
[gpadmin@master27 ~]$

 

谢谢,但是已经装了scp了

回复
Peter
帖子: 5
青梅新星
已加入: 2月 前

新节点的数据目录都有?

回复

关注微信公众号

Greenplum中文社区

Greenplum官方微信群

扫码加入我们的技术讨论,请备注“网站”